CVE-2019-5439

NameCVE-2019-5439
DescriptionA Buffer Overflow in VLC Media Player < 3.0.7 causes a crash which can possibly be further developed into a remote code execution exploit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4459-1
NVD severitymedium
Debian Bugs930276

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)stretch3.0.11-0+deb9u1fixed
stretch (security)3.0.11-0+deb9u2fixed
buster, buster (security)3.0.12-0+deb10u1fixed
bookworm, sid, bullseye3.0.16-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsourcejessie(unfixed)end-of-life
vlcsourcestretch3.0.7-0+deb9u1DSA-4459-1
vlcsource(unstable)3.0.7-1930276

Notes

[jessie] - vlc <end-of-life> (https://lists.debian.org/debian-security-announce/2018/msg00130.html)
https://hackerone.com/reports/484398
http://www.jbkempf.com/blog/post/2019/VLC-3.0.7-and-security

Search for package or bug name: Reporting problems