CVE-2019-5448

NameCVE-2019-5448
DescriptionYarn before 1.17.3 is vulnerable to Missing Encryption of Sensitive Data due to HTTP URLs in lockfile causing unencrypted authentication data to be sent over the network.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs941354

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-yarnpkg (PTS)buster1.13.0-1+deb10u1fixed
bullseye1.19.1-1fixed
sid1.21.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-yarnpkgsource(unstable)1.13.0-3941354
node-yarnpkgsourcebuster1.13.0-1+deb10u1

Notes

https://hackerone.com/reports/640904
https://github.com/ChALkeR/notes/blob/master/Yarn-vuln.md
https://github.com/yarnpkg/yarn/pull/7393
https://github.com/yarnpkg/yarn/commit/2f08a7405cc3f6fe47c30293050bb0ac94850932

Search for package or bug name: Reporting problems