CVE-2019-5815

NameCVE-2019-5815
DescriptionType confusion in xsltNumberFormatGetMultipleLevel prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3101-1, DSA-4500-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)buster, buster (security)90.0.4430.212-1~deb10u1fixed
bullseye104.0.5112.79-1~deb11u1fixed
bullseye (security)108.0.5359.94-1~deb11u1fixed
bookworm, sid108.0.5359.94-1fixed
libxslt (PTS)buster1.1.32-2.2~deb10u1vulnerable
buster (security)1.1.32-2.2~deb10u2fixed
bullseye (security), bullseye1.1.34-4+deb11u1fixed
bookworm, sid1.1.35-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsourcestretch(unfixed)end-of-life
chromiumsourcebuster76.0.3809.100-1~deb10u1DSA-4500-1
chromiumsource(unstable)74.0.3729.108-1
libxsltsourcebuster1.1.32-2.2~deb10u2DLA-3101-1
libxsltsource(unstable)1.1.34-2

Notes

[stretch] - chromium <end-of-life> (see DSA 4562)
https://bugs.chromium.org/p/chromium/issues/detail?id=930663
https://gitlab.gnome.org/GNOME/libxslt/commit/08b62c25871b38d5d573515ca8a065b4b8f64f6b (v1.1.34-rc2)

Search for package or bug name: Reporting problems