CVE-2019-5827

NameCVE-2019-5827
DescriptionInteger overflow in SQLite via WebSQL in Google Chrome prior to 74.0.3729.131 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4500-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chromium (PTS)stretch (security)73.0.3683.75-1~deb9u1vulnerable
buster73.0.3683.75-1vulnerable
buster (security)76.0.3809.100-1~deb10u1fixed
bullseye, sid76.0.3809.100-1fixed
sqlite3 (PTS)jessie3.8.7.1-1+deb8u2vulnerable
jessie (security)3.8.7.1-1+deb8u4vulnerable
stretch3.16.2-5+deb9u1vulnerable
buster3.27.2-3fixed
bullseye, sid3.30.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chromiumsource(unstable)75.0.3770.80-1
chromiumsourcebuster76.0.3809.100-1~deb10u1DSA-4500-1
sqlite3source(unstable)3.27.2-3

Notes

[stretch] - sqlite3 <no-dsa> (Minor issue; mainly with inpact in chromium)
[jessie] - sqlite3 <no-dsa> (Minor issue; mainly with inpact in chromium)
https://www.sqlite.org/src/info/07ee06fd390bfebe
https://www.sqlite.org/src/info/0b6ae032c28e7fe3

Search for package or bug name: Reporting problems