CVE-2019-6251

NameCVE-2019-6251
DescriptionWebKitGTK and WPE WebKit prior to version 2.24.1 are vulnerable to address bar spoofing upon certain JavaScript redirections. An attacker could cause malicious web content to be displayed as if for a trusted URI. This is similar to the CVE-2018-8383 issue in Microsoft Edge.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)jessie2.6.2+dfsg1-4vulnerable
stretch2.18.6-1~deb9u1vulnerable
buster2.26.1-3~deb10u1fixed
buster (security)2.26.2-1~deb10+1fixed
bullseye, sid2.26.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksource(unstable)2.24.1-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
[jessie] - webkit2gtk <ignored> (Not covered by security support in jessie)
https://gitlab.gnome.org/GNOME/epiphany/issues/532
https://bugs.webkit.org/show_bug.cgi?id=194131
https://bugs.webkit.org/show_bug.cgi?id=194208
https://webkitgtk.org/security/WSA-2019-0002.html

Search for package or bug name: Reporting problems