CVE-2019-6293

NameCVE-2019-6293
DescriptionAn issue was discovered in the function mark_beginning_as_normal in nfa.c in flex 2.6.4. There is a stack exhaustion problem caused by the mark_beginning_as_normal function making recursive calls to itself in certain scenarios involving lots of '*' characters. Remote attackers could leverage this vulnerability to cause a denial-of-service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs919428

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flex (PTS)jessie (security), jessie2.5.39-8+deb8u2vulnerable
stretch2.6.1-1.3vulnerable
buster, sid2.6.4-6.2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flexsource(unstable)(unfixed)low919428

Notes

[buster] - flex <no-dsa> (Minor issue)
[stretch] - flex <no-dsa> (Minor issue)
[jessie] - flex <no-dsa> (Minor issue)
https://github.com/westes/flex/issues/414

Search for package or bug name: Reporting problems