CVE-2019-6341

NameCVE-2019-6341
DescriptionIn Drupal 7 versions prior to 7.65; Drupal 8.6 versions prior to 8.6.13;Drupal 8.5 versions prior to 8.5.14. Under certain circumstances the File module/subsystem allows a malicious user to upload a file that can trigger a cross-site scripting (XSS) vulnerability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1746-1, DSA-4412-1
NVD severitylow
Debian Bugs925176

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
drupal7 (PTS)stretch7.52-2+deb9u11fixed
stretch (security)7.52-2+deb9u16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
drupal7sourcejessie7.32-1+deb8u16DLA-1746-1
drupal7sourcestretch7.52-2+deb9u7DSA-4412-1
drupal7source(unstable)(unfixed)925176

Notes

https://www.drupal.org/SA-CORE-2019-004

Search for package or bug name: Reporting problems