CVE-2019-6465

NameCVE-2019-6465
DescriptionControls for zone transfers may not be properly applied to Dynamically Loadable Zones (DLZs) if the zones are writable Versions affected: BIND 9.9.0 -> 9.10.8-P1, 9.11.0 -> 9.11.5-P2, 9.12.0 -> 9.12.3-P2, and versions 9.9.3-S1 -> 9.11.5-S3 of BIND 9 Supported Preview Edition. Versions 9.13.0 -> 9.13.6 of the 9.13 development branch are also affected. Versions prior to BIND 9.9.0 have not been evaluated for vulnerability to CVE-2019-6465.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1697-1, DSA-4440-1
NVD severitymedium
Debian Bugs922955

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)jessie1:9.9.5.dfsg-9+deb8u15vulnerable
jessie (security)1:9.9.5.dfsg-9+deb8u18fixed
stretch (security), stretch1:9.10.3.dfsg.P4-12.3+deb9u5fixed
bullseye, sid, buster1:9.11.5.P4+dfsg-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bind9source(unstable)1:9.11.5.P4+dfsg-1low922955
bind9sourcejessie1:9.9.5.dfsg-9+deb8u17DLA-1697-1
bind9sourcestretch1:9.10.3.dfsg.P4-12.3+deb9u5DSA-4440-1

Notes

https://kb.isc.org/docs/cve-2019-6465
https://gitlab.isc.org/isc-projects/bind9/commit/a9307de85e147f4756c75d15aa221d2262df7d67

Search for package or bug name: Reporting problems