CVE-2019-6486

NameCVE-2019-6486
DescriptionGo before 1.10.8 and 1.11.x before 1.11.5 mishandles P-521 and P-384 elliptic curves, which allows attackers to cause a denial of service (CPU consumption) or possibly conduct ECDH private key recovery attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1664-1, DSA-4379-1, DSA-4380-1
NVD severitymedium (attack range: remote)
Debian Bugs920548

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
golang (PTS)jessie2:1.3.3-1vulnerable
jessie (security)2:1.3.3-1+deb8u2fixed
golang-1.11 (PTS)buster (security)1.11.6-1+deb10u1fixed
buster, bullseye1.11.6-1fixed
sid1.11.13-1fixed
golang-1.12 (PTS)bullseye1.12.7-3fixed
sid1.12.9-2fixed
golang-1.7 (PTS)stretch1.7.4-2vulnerable
stretch (security)1.7.4-2+deb9u1fixed
golang-1.8 (PTS)stretch1.8.1-1vulnerable
stretch (security)1.8.1-1+deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
golangsource(unstable)(unfixed)medium
golangsourcejessie2:1.3.3-1+deb8u1mediumDLA-1664-1
golang-1.10source(unstable)(unfixed)medium
golang-1.11source(unstable)1.11.5-1medium
golang-1.12source(unstable)1.12~beta2-2medium920548
golang-1.7source(unstable)(unfixed)medium
golang-1.7sourcestretch1.7.4-2+deb9u1mediumDSA-4379-1
golang-1.8source(unstable)(unfixed)medium
golang-1.8sourcestretch1.8.1-1+deb9u1mediumDSA-4380-1

Notes

https://groups.google.com/forum/m/#!topic/golang-announce/mVeX35iXuSw
https://golang.org/issue/29903
https://github.com/golang/go/commit/42b42f71

Search for package or bug name: Reporting problems