CVE-2019-7146

NameCVE-2019-7146
DescriptionIn elfutils 0.175, there is a buffer over-read in the ebl_object_note function in eblobjnote.c in libebl. Remote attackers could leverage this vulnerability to cause a denial-of-service via a crafted elf file, as demonstrated by eu-readelf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs920911

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
elfutils (PTS)jessie0.159-4.2fixed
jessie (security)0.159-4.2+deb8u1fixed
stretch0.168-1fixed
bullseye, sid, buster0.176-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
elfutilssource(unstable)0.176-1920911
elfutilssourcejessie(not affected)
elfutilssourcestretch(not affected)

Notes

[stretch] - elfutils <not-affected> (Vulnerable code introduced in 0.175)
[jessie] - elfutils <not-affected> (Vulnerable code introduced in 0.175)
https://sourceware.org/bugzilla/show_bug.cgi?id=24075
https://sourceware.org/bugzilla/show_bug.cgi?id=24081
https://sourceware.org/git/?p=elfutils.git;a=commit;h=012018907ca05eb0ab51d424a596ef38fc87cae1
https://sourceware.org/git/?p=elfutils.git;a=commit;h=cd7ded3df43f655af945c869976401a602e46fcd

Search for package or bug name: Reporting problems