CVE-2019-7149

NameCVE-2019-7149
DescriptionA heap-based buffer over-read was discovered in the function read_srclines in dwarf_getsrclines.c in libdw in elfutils 0.175. A crafted input can cause segmentation faults, leading to denial-of-service, as demonstrated by eu-nm.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1689-1
NVD severitymedium (attack range: remote)
Debian Bugs920910

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
elfutils (PTS)jessie0.159-4.2vulnerable
jessie (security)0.159-4.2+deb8u1fixed
stretch0.168-1vulnerable
buster, bullseye, sid0.176-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
elfutilssource(unstable)0.176-1low920910
elfutilssourcejessie0.159-4.2+deb8u1mediumDLA-1689-1

Notes

[stretch] - elfutils <no-dsa> (Minor issue)
https://sourceware.org/bugzilla/show_bug.cgi?id=24102
https://sourceware.org/ml/elfutils-devel/2019-q1/msg00068.html
https://sourceware.org/git/?p=elfutils.git;a=commit;h=2562759d6fe5b364fe224852e64e8bda39eb2e35

Search for package or bug name: Reporting problems