CVE-2019-7150

NameCVE-2019-7150
DescriptionAn issue was discovered in elfutils 0.175. A segmentation fault can occur in the function elf64_xlatetom in libelf/elf32_xlatetom.c, due to dwfl_segment_report_module not checking whether the dyn data read from a core file is truncated. A crafted input can cause a program crash, leading to denial-of-service, as demonstrated by eu-stack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1689-1
NVD severitymedium (attack range: remote)
Debian Bugs920909

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
elfutils (PTS)jessie0.159-4.2vulnerable
jessie (security)0.159-4.2+deb8u1fixed
stretch0.168-1vulnerable
buster, sid0.176-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
elfutilssource(unstable)0.176-1low920909
elfutilssourcejessie0.159-4.2+deb8u1mediumDLA-1689-1

Notes

[stretch] - elfutils <no-dsa> (Minor issue)
https://sourceware.org/bugzilla/show_bug.cgi?id=24103
https://sourceware.org/ml/elfutils-devel/2019-q1/msg00070.html
https://sourceware.org/git/?p=elfutils.git;a=commit;h=da5c5336a1eaf519de246f7d9f0f5585e1d4ac59

Search for package or bug name: Reporting problems