CVE-2019-7175

NameCVE-2019-7175
DescriptionIn ImageMagick before 7.0.8-25, some memory leaks exist in DecodeImage in coders/pcd.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12vulnerable
jessie (security)8:6.8.9.9-5+deb8u17vulnerable
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u7vulnerable
bullseye, sid, buster8:6.9.10.23+dfsg-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)(unfixed)unimportant

Notes

https://github.com/ImageMagick/ImageMagick/commit/1e6a3ace073c9ec9c71e439c111d23c6e66cb6ae
https://github.com/ImageMagick/ImageMagick/issues/1450

Search for package or bug name: Reporting problems