CVE-2019-7304

NameCVE-2019-7304
DescriptionCanonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
snapd (PTS)stretch2.21-2fixed
buster, sid2.37.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
snapdsource(unstable)2.37.1-1high
snapdsourcestretch(not affected)

Notes

[stretch] - snapd <not-affected> (Vulnerable code introduced later)
https://bugs.launchpad.net/snapd/+bug/1813365
Introduced in 2.28, fixed in 2.37.1

Search for package or bug name: Reporting problems