DescriptionCanonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
snapd (PTS)buster2.37.4-1+deb10u1fixed
buster (security)2.37.4-1+deb10u3fixed
bullseye (security), bullseye2.49-1+deb11u2fixed
sid, trixie2.62-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
snapdsourcestretch(not affected)


[stretch] - snapd <not-affected> (Vulnerable code introduced later)
Introduced in 2.28, fixed in 2.37.1

Search for package or bug name: Reporting problems