CVE-2019-7397

NameCVE-2019-7397
DescriptionIn ImageMagick before 7.0.8-25 and GraphicsMagick through 1.3.31, several memory leaks exist in WritePDFImage in coders/pdf.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u7vulnerable
stretch (security), stretch1.3.30+hg15796-1~deb9u2vulnerable
buster1.4~hg15978-1fixed
sid1.4+really1.3.32-1fixed
imagemagick (PTS)jessie8:6.8.9.9-5+deb8u12vulnerable
jessie (security)8:6.8.9.9-5+deb8u16vulnerable
stretch8:6.9.7.4+dfsg-11+deb9u6vulnerable
stretch (security)8:6.9.7.4+dfsg-11+deb9u7vulnerable
buster, sid8:6.9.10.23+dfsg-2.1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.4~hg15896-1unimportant
imagemagicksource(unstable)(unfixed)unimportant

Notes

https://github.com/ImageMagick/ImageMagick/commit/306c1f0fa5754ca78efd16ab752f0e981d4f6b82
https://github.com/ImageMagick/ImageMagick/issues/1454

Search for package or bug name: Reporting problems