CVE-2019-7524

NameCVE-2019-7524
DescriptionIn Dovecot before 2.2.36.3 and 2.3.x before 2.3.5.1, a local attacker can cause a buffer overflow in the indexer-worker process, which can be used to elevate to root. This occurs because of missing checks in the fts and pop3-uidl components.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1736-1, DSA-4418-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dovecot (PTS)stretch1:2.2.27-3+deb9u5fixed
stretch (security)1:2.2.27-3+deb9u6fixed
buster1:2.3.4.1-5+deb10u4fixed
buster (security)1:2.3.4.1-5+deb10u3fixed
bullseye, sid1:2.3.11.3+dfsg1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dovecotsourcejessie1:2.2.13-12~deb8u6DLA-1736-1
dovecotsourcestretch1:2.2.27-3+deb9u4DSA-4418-1
dovecotsource(unstable)1:2.3.4.1-3

Notes

https://github.com/dovecot/core/commit/37eeaef1587a3b99be97cb090094de19e374905c
https://github.com/dovecot/core/commit/a02c16889f1f3411e9a16b96221c2795d5fdb974

Search for package or bug name: Reporting problems