CVE-2019-8308

NameCVE-2019-8308
DescriptionFlatpak before 1.0.7, and 1.1.x and 1.2.x before 1.2.3, exposes /proc in the apply_extra script sandbox, which allows attackers to modify a host-side executable file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4390-1
NVD severitymedium
Debian Bugs922059

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flatpak (PTS)stretch0.8.9-0+deb9u3fixed
stretch (security)0.8.9-0+deb9u2fixed
buster, buster (security)1.2.5-0+deb10u4fixed
bullseye1.10.3-0+deb11u1fixed
bullseye (security)1.10.5-0+deb11u1fixed
bookworm, sid1.12.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flatpaksourcestretch0.8.9-0+deb9u2DSA-4390-1
flatpaksource(unstable)1.2.3-1922059

Search for package or bug name: Reporting problems