CVE-2019-8720

NameCVE-2019-8720
DescriptionA vulnerability was found in WebKit. The flaw is triggered when processing maliciously crafted web content that may lead to arbitrary code execution. Improved memory handling addresses the multiple memory corruption issues.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-4558-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)buster2.36.4-1~deb10u1fixed
buster (security)2.38.6-0+deb10u1fixed
bullseye2.42.2-1~deb11u1fixed
bullseye (security)2.42.5-1~deb11u1fixed
bookworm2.42.2-1~deb12u1fixed
bookworm (security)2.42.5-1~deb12u1fixed
sid, trixie2.42.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksourcebuster2.26.1-3~deb10u1DSA-4558-1
webkit2gtksource(unstable)2.26.0-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
[jessie] - webkit2gtk <ignored> (Not covered by security support in jessie)
https://webkitgtk.org/security/WSA-2019-0005.html

Search for package or bug name: Reporting problems