CVE-2019-8842

NameCVE-2019-8842
Descriptionhe `ippReadIO` function may under-read an extension field
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2237-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cups (PTS)stretch2.2.1-8+deb9u5vulnerable
stretch (security)2.2.1-8+deb9u2vulnerable
buster2.2.10-6+deb10u3fixed
bullseye, sid2.3.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cupssource(unstable)2.3.1-12
cupssourcebuster2.2.10-6+deb10u3
cupssourcejessie1.7.5-11+deb8u8DLA-2237-1

Notes

[stretch] - cups <no-dsa> (Minor issue)
https://github.com/apple/cups/commit/82e3ee0e3230287b76a76fb8f16b92ca6e50b444 (cups/ipp.c: ippReadIO)

Search for package or bug name: Reporting problems