CVE-2019-8904

NameCVE-2019-8904
Descriptiondo_bid_note in readelf.c in libmagic.a in file 5.35 has a stack-based buffer over-read, related to file_printf and file_vprintf.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs922967

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)jessie1:5.22+15-2+deb8u4fixed
jessie (security)1:5.22+15-2+deb8u7fixed
stretch1:5.30-1+deb9u2fixed
stretch (security)1:5.30-1+deb9u3fixed
buster, buster (security)1:5.35-4+deb10u1fixed
bullseye1:5.38-3fixed
sid1:5.38-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.35-3922967
filesourcejessie(not affected)
filesourcestretch(not affected)

Notes

[stretch] - file <not-affected> (vulnerable code introduced later)
[jessie] - file <not-affected> (vulnerable code introduced later)
https://bugs.astron.com/view.php?id=62
Introduced by: https://github.com/file/file/commit/76c55eae2f9b0b378332762f6dce544d05eb24d7 (FILE5_34)
Fixed by: https://github.com/file/file/commit/94b7501f48e134e77716e7ebefc73d6bbe72ba55 (FILE5_36)

Search for package or bug name: Reporting problems