CVE-2019-8905

NameCVE-2019-8905
Descriptiondo_core_note in readelf.c in libmagic.a in file 5.35 has a stack-based buffer over-read, related to file_printable, a different vulnerability than CVE-2018-10360.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1698-1
NVD severitymedium (attack range: remote)
Debian Bugs922968

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)jessie1:5.22+15-2+deb8u4vulnerable
jessie (security)1:5.22+15-2+deb8u5fixed
stretch1:5.30-1+deb9u2vulnerable
stretch (security)1:5.30-1+deb9u1vulnerable
buster1:5.35-4fixed
bullseye, sid1:5.37-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)1:5.35-3medium922968
filesourcejessie1:5.22+15-2+deb8u5mediumDLA-1698-1

Notes

[stretch] - file <no-dsa> (Minor issue; will be fixed in point release)
https://bugs.astron.com/view.php?id=63
https://github.com/file/file/commit/d65781527c8134a1202b2649695d48d5701ac60b

Search for package or bug name: Reporting problems