CVE-2019-8906

NameCVE-2019-8906
Descriptiondo_core_note in readelf.c in libmagic.a in file 5.35 has an out-of-bounds read because memcpy is misused.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs922969

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)stretch, stretch (security)1:5.30-1+deb9u3fixed
buster, buster (security)1:5.35-4+deb10u1fixed
bullseye1:5.38-5fixed
sid1:5.39-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesourcejessie(not affected)
filesourcestretch(not affected)
filesource(unstable)1:5.35-3922969

Notes

[stretch] - file <not-affected> (vulnerable code introduced later)
[jessie] - file <not-affected> (vulnerable code introduced later)
https://bugs.astron.com/view.php?id=64
Introduced by: https://github.com/file/file/commit/0ac0678c52e248fd2a632a84b638694f205aef9d (FILE5_31)
Fixed by: https://github.com/file/file/commit/2858eaf99f6cc5aae129bcbf1e24ad160240185f (FILE5_36)

Search for package or bug name: Reporting problems