CVE-2019-8942

NameCVE-2019-8942
DescriptionWordPress before 4.9.9 and 5.x before 5.0.1 allows remote code execution because an _wp_attached_file Post Meta entry can be changed to an arbitrary string, such as one ending with a .jpg?file.php substring. An attacker with author privileges can execute arbitrary code by uploading a crafted image containing PHP code in the Exif metadata. Exploitation can leverage CVE-2019-8943.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1742-1, DSA-4401-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)jessie4.1+dfsg-1+deb8u17vulnerable
jessie (security)4.1.26+dfsg-1+deb8u1fixed
stretch (security), stretch4.7.5+dfsg-2+deb9u5fixed
bullseye, buster5.0.4+dfsg1-1fixed
sid5.2.3+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wordpresssource(unstable)5.0.1+dfsg1-1medium
wordpresssourcejessie4.1.26+dfsg-1+deb8u1mediumDLA-1742-1
wordpresssourcestretch4.7.5+dfsg-2+deb9u5mediumDSA-4401-1

Notes

https://blog.ripstech.com/2019/wordpress-image-remote-code-execution/
Issue fixed in 4.9.9 and 5.0.1 upstream

Search for package or bug name: Reporting problems