CVE-2019-9085

NameCVE-2019-9085
DescriptionHoteldruid before v2.3.1 allows remote authenticated users to cause a denial of service (invoice-creation outage) via the n_file parameter to visualizza_contratto.php with invalid arguments (any non-numeric value), as demonstrated by the anno=2019&id_transazione=1&numero_contratto=1&n_file=a query string to visualizza_contratto.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hoteldruid (PTS)stretch2.2.0-1vulnerable
buster2.3.2-1fixed
bullseye3.0.1-1fixed
bookworm, sid3.0.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hoteldruidsource(unstable)2.3.2-1

Notes

[stretch] - hoteldruid <ignored> (Minor issue)
[jessie] - hoteldruid <no-dsa> (low popcon)

Search for package or bug name: Reporting problems