CVE-2019-9187

NameCVE-2019-9187
Descriptionikiwiki before 3.20170111.1 and 3.2018x and 3.2019x before 3.20190226 allows SSRF via the aggregate plugin. The impact also includes reading local files via file: URIs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1716-1, DSA-4399-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ikiwiki (PTS)jessie3.20141016.4vulnerable
jessie (security)3.20141016.4+deb8u1fixed
stretch (security), stretch3.20170111.1fixed
bullseye, sid, buster3.20190228-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ikiwikisource(unstable)3.20190228-1medium
ikiwikisourcejessie3.20141016.4+deb8u1mediumDLA-1716-1
ikiwikisourcestretch3.20170111.1mediumDSA-4399-1

Notes

https://ikiwiki.info/security/#cve-2019-9187
https://www.openwall.com/lists/oss-security/2019/02/28/1
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=e7b0d4a
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=67543ce
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=d283e4c
http://source.ikiwiki.branchable.com/?p=source.git;a=commitdiff;h=9a275b2

Search for package or bug name: Reporting problems