CVE-2019-9192

NameCVE-2019-9192
Description** DISPUTED ** In the GNU C Library (aka glibc or libc6) through 2.29, check_dst_limits_calc_pos_1 in posix/regexec.c has Uncontrolled Recursion, as demonstrated by '(|)(\\1\\1)*' in grep, a different issue than CVE-2018-20796. NOTE: the software maintainer disputes that this is a vulnerability because the behavior occurs only with a crafted pattern.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
glibc (PTS)jessie (security), jessie2.19-18+deb8u10vulnerable
stretch2.24-11+deb9u4vulnerable
stretch (security)2.24-11+deb9u1vulnerable
bullseye, sid, buster2.28-10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eglibcsource(unstable)(unfixed)unimportant
glibcsource(unstable)(unfixed)unimportant

Notes

https://sourceware.org/bugzilla/show_bug.cgi?id=24269

Search for package or bug name: Reporting problems