CVE-2019-9494

NameCVE-2019-9494
DescriptionThe implementations of SAE in hostapd and wpa_supplicant are vulnerable to side channel attacks as a result of observable timing differences and cache access patterns. An attacker may be able to gain leaked information from a side channel attack that can be used for full password recovery. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.7 are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs926801

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie2.3-1+deb8u5vulnerable
jessie (security)2.3-1+deb8u7vulnerable
stretch2:2.4-1+deb9u2vulnerable
stretch (security)2:2.4-1+deb9u3vulnerable
buster, sid2:2.7+git20190128+0c1e29f-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasource(unstable)2:2.7+git20190128+0c1e29f-4medium926801

Notes

[stretch] - wpa <ignored> (SAE code not enabled for build in stretch)
[jessie] - wpa <ignored> (SAE code not enabled for build in jessie)
https://w1.fi/security/2019-1/sae-side-channel-attacks.txt
Patches: https://w1.fi/security/2019-1/
CONFIG_SAE=y enabled since 2:2.7~git20180706+420b5dd-1

Search for package or bug name: Reporting problems