CVE-2019-9495

NameCVE-2019-9495
DescriptionThe implementations of EAP-PWD in hostapd and wpa_supplicant are vulnerable to side-channel attacks as a result of cache access patterns. All versions of hostapd and wpa_supplicant with EAP-PWD support are vulnerable. The ability to install and execute applications is necessary for a successful attack. Memory access patterns are visible in a shared cache. Weak passwords may be cracked. Versions of hostapd/wpa_supplicant 2.7 and newer, are not vulnerable to the timing attack described in CVE-2019-9494. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4430-1
NVD severitymedium (attack range: remote)
Debian Bugs926801

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie2.3-1+deb8u5vulnerable
jessie (security)2.3-1+deb8u7vulnerable
stretch2:2.4-1+deb9u3fixed
stretch (security)2:2.4-1+deb9u4fixed
buster2:2.7+git20190128+0c1e29f-5fixed
sid2:2.7+git20190128+0c1e29f-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasource(unstable)2:2.7+git20190128+0c1e29f-4medium926801
wpasourcestretch2:2.4-1+deb9u3mediumDSA-4430-1

Notes

https://w1.fi/security/2019-2/eap-pwd-side-channel-attack.txt
Patches: https://w1.fi/security/2019-2/

Search for package or bug name: Reporting problems