DescriptionAn invalid authentication sequence could result in the hostapd process terminating due to missing state validation steps when processing the SAE confirm message when in hostapd/AP mode. All version of hostapd with SAE support are vulnerable. An attacker may force the hostapd process to terminate, performing a denial of service attack. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.7 are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs926801

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)bullseye2:2.9.0-21+deb11u1fixed
trixie, sid2:2.10-21.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[stretch] - wpa <ignored> (SAE code not enabled for build in stretch)
[jessie] - wpa <ignored> (SAE code not enabled for build in jessie)
CONFIG_SAE=y enabled since 2:2.7~git20180706+420b5dd-1

Search for package or bug name: Reporting problems