CVE-2019-9498

NameCVE-2019-9498
DescriptionThe implementations of EAP-PWD in hostapd EAP Server, when built against a crypto library missing explicit validation on imported elements, do not validate the scalar and element values in EAP-pwd-Commit. An attacker may be able to use invalid scalar/element values to complete authentication, gaining session key and network access without needing or learning the password. Both hostapd with SAE support and wpa_supplicant with SAE support prior to and including version 2.4 are affected. Both hostapd with EAP-pwd support and wpa_supplicant with EAP-pwd support prior to and including version 2.7 are affected.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4430-1
NVD severitymedium (attack range: remote)
Debian Bugs926801

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wpa (PTS)jessie2.3-1+deb8u5vulnerable
jessie (security)2.3-1+deb8u7vulnerable
stretch (security), stretch2:2.4-1+deb9u3fixed
buster, sid2:2.7+git20190128+0c1e29f-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wpasource(unstable)2:2.7+git20190128+0c1e29f-4medium926801
wpasourcestretch2:2.4-1+deb9u3mediumDSA-4430-1

Notes

https://w1.fi/security/2019-4/eap-pwd-missing-commit-validation.txt
Patches: https://w1.fi/security/2019-4/

Search for package or bug name: Reporting problems