CVE-2019-9517

NameCVE-2019-9517
DescriptionSome HTTP/2 implementations are vulnerable to unconstrained interal data buffering, potentially leading to a denial of service. The attacker opens the HTTP/2 window so the peer can send without constraint; however, they leave the TCP window closed so the peer cannot actually write (many of) the bytes on the wire. The attacker then sends a stream of requests for a large response object. Depending on how the servers queue the responses, this can consume excess memory, CPU, or both.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4509-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie2.4.10-10+deb8u12fixed
jessie (security)2.4.10-10+deb8u16fixed
stretch2.4.25-3+deb9u8fixed
stretch (security)2.4.25-3+deb9u9fixed
buster2.4.38-3+deb10u1fixed
buster (security)2.4.38-3+deb10u3fixed
bullseye, sid2.4.41-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.41-1high
apache2sourcebuster2.4.38-3+deb10u1highDSA-4509-1
apache2sourcejessie(not affected)
apache2sourcestretch2.4.25-3+deb9u8highDSA-4509-1

Notes

[jessie] - apache2 <not-affected> (HTTP/2 support only available since version 2.4.17 and later)
Affects upstream versions 2.4.20 to 2.4.39
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2019-9517
https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-002.md

Search for package or bug name: Reporting problems