CVE-2019-9518

NameCVE-2019-9518
DescriptionSome HTTP/2 implementations are vulnerable to a flood of empty frames, potentially leading to a denial of service. The attacker sends a stream of frames with an empty payload and without the end-of-stream flag. These frames can be DATA, HEADERS, CONTINUATION and/or PUSH_PROMISE. The peer spends time processing each frame disproportionate to attack bandwidth. This can consume excess CPU.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4520-1
NVD severityhigh
Debian Bugs935314

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
trafficserver (PTS)buster, buster (security)8.0.2+ds-1+deb10u5fixed
bookworm, bullseye8.1.1+ds-1.1fixed
sid9.1.0+ds-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
trafficserversourcebuster8.0.2+ds-1+deb10u1DSA-4520-1
trafficserversource(unstable)8.0.5+ds-1935314

Notes

https://github.com/Netflix/security-bulletins/blob/master/advisories/third-party/2019-002.md
https://github.com/apache/trafficserver/pull/5850
https://github.com/apache/trafficserver/blob/8.0.x/CHANGELOG-8.0.5

Search for package or bug name: Reporting problems