CVE-2019-9792

NameCVE-2019-9792
DescriptionThe IonMonkey just-in-time (JIT) compiler can leak an internal JS_OPTIMIZED_OUT magic value to the running script during a bailout. This magic value can then be used by JavaScript to achieve memory corruption, which results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1722-1, DLA-1743-1, DSA-4411-1, DSA-4420-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid82.0-1fixed
firefox-esr (PTS)stretch68.10.0esr-1~deb9u1fixed
stretch (security)78.4.0esr-1~deb9u1fixed
buster68.12.0esr-1~deb10u1fixed
buster (security)78.4.0esr-1~deb10u2fixed
bullseye78.3.0esr-2fixed
sid78.4.0esr-2fixed
thunderbird (PTS)stretch1:68.10.0-1~deb9u1fixed
stretch (security)1:78.3.1-2~deb9u1fixed
buster1:68.12.0-1~deb10u1fixed
buster (security)1:78.3.1-2~deb10u2fixed
bullseye1:68.12.0-1fixed
sid1:78.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)66.0-1
firefox-esrsourcejessie60.6.0esr-1~deb8u1DLA-1722-1
firefox-esrsourcestretch60.6.0esr-1~deb9u1DSA-4411-1
firefox-esrsource(unstable)60.6.0esr-1
thunderbirdsourcejessie1:60.6.1-1~deb8u1DLA-1743-1
thunderbirdsourcestretch1:60.6.1-1~deb9u1DSA-4420-1
thunderbirdsource(unstable)1:60.6.1-1

Notes

https://www.mozilla.org/en-US/security/advisories/mfsa2019-08/#CVE-2019-9792
https://www.mozilla.org/en-US/security/advisories/mfsa2019-07/#CVE-2019-9792
https://www.mozilla.org/en-US/security/advisories/mfsa2019-11/#CVE-2019-9792

Search for package or bug name: Reporting problems