CVE-2019-9834

NameCVE-2019-9834
Description** DISPUTED ** The Netdata web application through 1.13.0 allows remote attackers to inject their own malicious HTML code into an imported snapshot, aka HTML Injection. Successful exploitation will allow attacker-supplied HTML to run in the context of the affected browser, potentially allowing the attacker to steal authentication credentials or to control how the site is rendered to the user. NOTE: the vendor disputes the risk because there is a clear warning next to the button for importing a snapshot.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netdata (PTS)buster1.12.0-1+deb10u1vulnerable
bullseye, sid1.19.0-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netdatasource(unstable)(unfixed)unimportant

Notes

https://github.com/netdata/netdata/issues/5800#issuecomment-510986112
Risk disupted by upstream because there is a clear warning next to the
button for importing a snapshot, thus treat the issue as unimportant with
negligible impact.

Search for package or bug name: Reporting problems