CVE-2019-9895

NameCVE-2019-9895
DescriptionIn PuTTY versions before 0.71 on Unix, a remotely triggerable buffer overflow exists in any kind of server-to-client forwarding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4423-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
putty (PTS)stretch (security), stretch0.67-3+deb9u1fixed
buster0.70-6fixed
bullseye0.74-1fixed
bookworm, sid0.76-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puttysourcestretch0.67-3+deb9u1DSA-4423-1
puttysource(unstable)0.70-6

Notes

[jessie] - putty <ignored> (Too intrusive to backport, patch uses callback handling that is not yet available in Jessie)
https://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-fd-set-overflow.html
https://git.tartarus.org/?p=simon/putty.git;a=commitdiff;h=5c926d9ea4a9e0a0a2384f06c7583648cdff3ed6

Search for package or bug name: Reporting problems