CVE-2019-9898

NameCVE-2019-9898
DescriptionPotential recycling of random numbers used in cryptography exists within PuTTY before 0.71.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1763-1, DSA-4423-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
putty (PTS)stretch (security), stretch0.67-3+deb9u1fixed
buster0.70-6fixed
bullseye0.74-1fixed
bookworm, sid0.76-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puttysourcejessie0.63-10+deb8u2DLA-1763-1
puttysourcestretch0.67-3+deb9u1DSA-4423-1
puttysource(unstable)0.70-6

Notes

https://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist/vuln-rng-reuse.html
https://git.tartarus.org/?p=simon/putty.git;a=commitdiff;h=320bf8479ff5bcbad239db4f9f4aa63656b0675e

Search for package or bug name: Reporting problems