DescriptionZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs925285

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
znc (PTS)jessie1.4-2fixed
jessie (security)1.4-2+deb8u1fixed
stretch (security), stretch1.6.5-1+deb9u1vulnerable
buster, sid1.7.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zncsourcejessie(not affected)


[jessie] - znc <not-affected> (The vulnerable code is not present)

Search for package or bug name: Reporting problems