CVE-2019-9917

NameCVE-2019-9917
DescriptionZNC before 1.7.3-rc1 allows an existing remote user to cause a Denial of Service (crash) via invalid encoding.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4463-1
NVD severitymedium (attack range: remote)
Debian Bugs925285

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
znc (PTS)jessie1.4-2vulnerable
jessie (security)1.4-2+deb8u2vulnerable
stretch1.6.5-1+deb9u1vulnerable
stretch (security)1.6.5-1+deb9u2fixed
bullseye, buster1.7.2-3fixed
sid1.7.4-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zncsource(unstable)1.7.2-2medium925285
zncsourcestretch1.6.5-1+deb9u2mediumDSA-4463-1

Notes

[jessie] - znc <ignored> (Minor issue, workaround is to disable modpython)
https://github.com/znc/znc/commit/64613bc8b6b4adf1e32231f9844d99cd512b8973
Every version between 0.096 and 1.7.2 (incl) is vulnerable to the issue,
but earlier versions could not be fixed without a major rewrite. A workaround
though is to disable modpython.

Search for package or bug name: Reporting problems