CVE-2019-9924

NameCVE-2019-9924
Descriptionrbash in Bash before 4.4-beta2 did not prevent the shell user from modifying BASH_CMDS, thus allowing the user to execute any command with the permissions of the shell.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1726-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bash (PTS)jessie4.3-11+deb8u1vulnerable
jessie (security)4.3-11+deb8u2fixed
stretch4.4-5fixed
buster5.0-4fixed
bullseye, sid5.0-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bashsource(unstable)4.4-1low
bashsourcejessie4.3-11+deb8u2DLA-1726-1

Notes

https://bugs.launchpad.net/ubuntu/+source/bash/+bug/1803441

Search for package or bug name: Reporting problems