CVE-2020-0093

NameCVE-2020-0093
DescriptionIn exif_data_save_data_entry of exif-data.c, there is a possible out of bounds read due to a missing bounds check. This could lead to local information disclosure with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-8.0 Android-8.1 Android-9 Android-10Android ID: A-148705132
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2214-1
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libexif (PTS)jessie, stretch0.6.21-2vulnerable
jessie (security)0.6.21-2+deb8u3fixed
stretch (security)0.6.21-2+deb9u1vulnerable
buster, buster (security)0.6.21-5.1+deb10u1vulnerable
bullseye, sid0.6.21-9fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libexifsource(unstable)0.6.21-8
libexifsourcejessie0.6.21-2+deb8u2DLA-2214-1

Notes

[buster] - libexif <no-dsa> (Minor issue)
[stretch] - libexif <no-dsa> (Minor issue)
https://github.com/libexif/libexif/issues/42
https://github.com/libexif/libexif/commit/5ae5973bed1947f4d447dc80b76d5cefadd90133

Search for package or bug name: Reporting problems