CVE-2020-0499

NameCVE-2020-0499
DescriptionIn FLAC__bitreader_read_rice_signed_block of bitreader.c, there is a possible out of bounds read due to a heap buffer overflow. This could lead to remote information disclosure with no additional execution privileges needed. User interaction is needed for exploitation.Product: AndroidVersions: Android-11Android ID: A-156076070
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2514-1
NVD severitymedium
Debian Bugs977764

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
flac (PTS)stretch1.3.2-1vulnerable
stretch (security)1.3.2-2+deb9u1fixed
buster1.3.2-3vulnerable
bullseye, sid1.3.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
flacsourcestretch1.3.2-2+deb9u1DLA-2514-1
flacsource(unstable)1.3.3-2977764

Notes

[buster] - flac <no-dsa> (Minor issue)
https://github.com/xiph/flac/commit/2e7931c27eb15e387da440a37f12437e35b22dd4
https://android.googlesource.com/platform/external/flac/+/029048f823ced50f63a92e25073427ec3a9bd909%5E%21/#F0
https://source.android.com/security/bulletin/pixel/2020-12-01

Search for package or bug name: Reporting problems