CVE-2020-0570

NameCVE-2020-0570
DescriptionUncontrolled search path in the QT Library before 5.14.0, 5.12.7 and 5.9.10 may allow an authenticated user to potentially enable elevation of privilege via local access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qtbase-opensource-src (PTS)stretch (security), stretch5.7.1+dfsg-3+deb9u2fixed
buster5.11.3+dfsg1-1+deb10u4fixed
buster (security)5.11.3+dfsg1-1+deb10u3fixed
bullseye, sid5.14.2+dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qtbase-opensource-srcsourcejessie(not affected)
qtbase-opensource-srcsourcestretch(not affected)
qtbase-opensource-srcsourcebuster5.11.3+dfsg1-1+deb10u3
qtbase-opensource-srcsource(unstable)5.12.5+dfsg-8

Notes

[stretch] - qtbase-opensource-src <not-affected> (Only affects 5.12.0 through 5.14.0)
[jessie] - qtbase-opensource-src <not-affected> (Only affects 5.12.0 through 5.14.0)
https://bugreports.qt.io/browse/QTBUG-81272
Patch: https://code.qt.io/cgit/qt/qtbase.git/commit/?id=e6f1fde24f77f63fb16b2df239f82a89d2bf05dd
https://lists.qt-project.org/pipermail/development/2020-January/038534.html

Search for package or bug name: Reporting problems