CVE-2020-10018

NameCVE-2020-10018
DescriptionWebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4641-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
webkit2gtk (PTS)jessie2.6.2+dfsg1-4vulnerable
stretch2.18.6-1~deb9u1vulnerable
buster2.26.3-1~deb10u1vulnerable
buster (security)2.26.4-1~deb10u2fixed
bullseye, sid2.28.0-2fixed
wpewebkit (PTS)bullseye, sid2.28.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
webkit2gtksource(unstable)2.28.0-2
webkit2gtksourcebuster2.26.4-1~deb10u2DSA-4641-1
wpewebkitsource(unstable)2.28.0-1

Notes

[stretch] - webkit2gtk <ignored> (Not covered by security support in stretch)
[jessie] - webkit2gtk <ignored> (Not covered by security support in jessie)
https://webkitgtk.org/security/WSA-2020-0003.html

Search for package or bug name: Reporting problems