CVE-2020-10177

NameCVE-2020-10177
DescriptionPillow before 7.1.0 has multiple out-of-bounds reads in libImaging/FliDecode.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2317-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)bullseye (security), bullseye8.1.2+dfsg-0.3+deb11u2fixed
bookworm, bookworm (security)9.4.0-1.1+deb12u1fixed
sid, trixie10.4.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsourcestretch4.0.0-4+deb9u2DLA-2317-1
pillowsourcebuster5.4.1-2+deb10u2
pillowsource(unstable)7.2.0-1

Notes

https://github.com/python-pillow/Pillow/pull/4503
https://github.com/python-pillow/Pillow/pull/4538
Fixed in 6.2.3 and 7.1.0

Search for package or bug name: Reporting problems