CVE-2020-10577

NameCVE-2020-10577
DescriptionAn issue was discovered in Janus through 0.9.1. janus.c has multiple concurrent threads that misuse the source property of a session, leading to a race condition when claiming sessions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs954668

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
janus (PTS)buster0.6.1-1vulnerable
bullseye, sid0.9.1+20200313-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
janussource(unstable)(unfixed)954668

Notes

https://github.com/meetecho/janus-gateway/pull/1990

Search for package or bug name: Reporting problems