CVE-2020-10593

NameCVE-2020-10593
DescriptionTor before 0.3.5.10, 0.4.x before 0.4.1.9, and 0.4.2.x before 0.4.2.7 allows remote attackers to cause a Denial of Service (memory leak), aka TROVE-2020-004. This occurs in circpad_setup_machine_on_circ because a circuit-padding machine can be negotiated twice on the same circuit.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tor (PTS)jessie (security), jessie0.2.5.16-1fixed
stretch0.2.9.16-1fixed
stretch (security)0.2.9.15-1fixed
buster0.3.5.8-1fixed
buster (security)0.3.5.10-1fixed
bullseye, sid0.4.2.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
torsource(unstable)0.4.2.7-1
torsourcebuster(not affected)
torsourcejessie(not affected)
torsourcestretch(not affected)

Notes

[buster] - tor <not-affected> (Only affects tor 0.4.0.1-alpha onwards)
[stretch] - tor <not-affected> (Only affects tor 0.4.0.1-alpha onwards)
[jessie] - tor <not-affected> (Only affects tor 0.4.0.1-alpha onwards)
https://blog.torproject.org/new-releases-03510-0419-0427
https://bugs.torproject.org/33619

Search for package or bug name: Reporting problems