CVE-2020-10759

NameCVE-2020-10759
DescriptionA PGP signature bypass flaw was found in fwupd, which could lead to the installation of unsigned firmware. As per upstream, a signature bypass is theoretically possible, but not practical because the Linux Vendor Firmware Service (LVFS) is either not implemented or enabled in versions of fwupd shipped with Red Hat Enterprise Linux 7 and 8. The highest threat from this vulnerability is to confidentiality and integrity.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-2274-1
Debian Bugs962517

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
fwupd (PTS)buster1.2.14-1~deb10u1fixed
bullseye1.5.7-4fixed
bookworm, sid1.8.10-2fixed
libjcat (PTS)bullseye0.1.3-2fixed
bookworm, sid0.1.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fwupdsourcestretch0.7.4-2+deb9u1DLA-2274-1
fwupdsourcebuster1.2.13-1
fwupdsource(unstable)1.3.10-1962517
libjcatsource(unstable)0.1.3-1

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1844316
https://github.com/justinsteven/advisories/blob/master/2020_fwupd_dangling_s3_bucket_and_CVE-2020-10759_signature_verification_bypass.md
Fixed by: https://github.com/fwupd/fwupd/commit/21f2d12fccef63b8aaa99ec53278ce18250b0444 (1.3.10)
Introduced with: https://github.com/fwupd/fwupd/commit/36a889034c3d34ae4ac4530ea7b6b16e82476fae (0.1.2)
https://github.com/hughsie/libjcat/commit/839b89f45a38b2373bf5836337a33f450aaab72e

Search for package or bug name: Reporting problems