CVE-2020-10760

NameCVE-2020-10760
DescriptionA use-after-free flaw was found in all samba LDAP server versions before 4.10.17, before 4.11.11, before 4.12.4 used in a AC DC configuration. A Samba LDAP user could use this flaw to crash samba.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)stretch (security), stretch2:4.5.16+dfsg-1+deb9u2vulnerable
buster2:4.9.5+dfsg-5vulnerable
buster (security)2:4.9.5+dfsg-5+deb10u1vulnerable
bullseye, sid2:4.12.5+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:4.12.5+dfsg-1

Notes

[buster] - samba <postponed> (Minor issue, fix along in next DSA)
https://www.samba.org/samba/security/CVE-2020-10760.html

Search for package or bug name: Reporting problems