CVE-2020-10802

NameCVE-2020-10802
DescriptionIn phpMyAdmin 4.x before 4.9.5 and 5.x before 5.0.2, a SQL injection vulnerability has been discovered where certain parameters are not properly escaped when generating certain queries for search actions in libraries/classes/Controllers/Table/TableSearchController.php. An attacker can generate a crafted database or table name. The attack can be performed if a user attempts certain search operations on the malicious database or table.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2154-1
NVD severitymedium
Debian Bugs954665

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)jessie4:4.2.12-2+deb8u2vulnerable
jessie (security)4:4.2.12-2+deb8u9fixed
stretch4:4.6.6-4vulnerable
bullseye4:4.9.4+dfsg1-1vulnerable
sid4:4.9.5+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:4.9.5+dfsg1-1954665
phpmyadminsourcejessie4:4.2.12-2+deb8u9DLA-2154-1

Notes

[stretch] - phpmyadmin <no-dsa> (Minor issue)
https://www.phpmyadmin.net/security/PMASA-2020-3/
https://github.com/phpmyadmin/phpmyadmin/commit/a8acd7a42cf743186528b0453f90aaa32bfefabe

Search for package or bug name: Reporting problems