CVE-2020-10931

NameCVE-2020-10931
DescriptionMemcached 1.6.x before 1.6.2 allows remote attackers to cause a denial of service (daemon crash) via a crafted binary protocol header to try_read_command_binary in memcached.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs954808

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
memcached (PTS)jessie1.4.21-1.1+deb8u2fixed
jessie (security)1.4.21-1.1+deb8u3fixed
stretch (security), stretch1.4.33-1+deb9u1fixed
buster1.5.6-1.1fixed
bullseye1.5.22-2vulnerable
sid1.6.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
memcachedsource(unstable)1.6.2-1954808
memcachedsourcebuster(not affected)
memcachedsourcejessie(not affected)
memcachedsourcestretch(not affected)

Notes

[buster] - memcached <not-affected> (Introduced in 1.6)
[stretch] - memcached <not-affected> (Introduced in 1.6)
[jessie] - memcached <not-affected> (Introduced in 1.6)
https://github.com/memcached/memcached/issues/629
https://github.com/memcached/memcached/commit/02c6a2b62ddcb6fa4569a591d3461a156a636305

Search for package or bug name: Reporting problems