CVE-2020-10938

NameCVE-2020-10938
DescriptionGraphicsMagick before 1.3.35 has an integer overflow and resultant heap-based buffer overflow in HuffmanDecodeImage in magick/compress.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2vulnerable
jessie (security)1.3.20-3+deb8u9vulnerable
stretch1.3.30+hg15796-1~deb9u2vulnerable
stretch (security)1.3.30+hg15796-1~deb9u3vulnerable
buster1.4~hg15978-1vulnerable
buster (security)1.4~hg15978-1+deb10u1vulnerable
bullseye, sid1.4+really1.3.35-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.4+really1.3.34-1

Notes

http://hg.graphicsmagick.org/hg/GraphicsMagick/rev/95abc2b694ce

Search for package or bug name: Reporting problems